Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 24, 2025 - 17:00 HKT
Scheduled
Router in Taipei, Taiwan, will be taken offline to configure the port connecting to the Taipei Internet eXchange (TPIX). No service interruption is expected during this maintenance.
Affected router: tw-tpe01.
Posted Oct 24, 2025 - 12:00 HKT
This scheduled maintenance affected: Infrastructure (Asia).